+ Reply to Thread
Results 1 to 5 of 5
  1. RS6
    RS6 is offline
    Junior Member Registered Member
    Join Date
    Dec 2015
    Posts
    4
    #1

    Default Have you ever thought too hard at made it more difficult than it is...please help

    I know I'm thinking to deep into this but I need clarification

    Ex. ROAS with 2 Vlans. Vlan 2 is part of x.x.0.0 /24 and Vlan 3 part of x.x.1.0/24. I want to verify that sub int for x.x.0.0 will have an IP address in x.x.0.0 as well as Vlan 3 having an ip address in x.x.1.0. I got that part but the physical port/trunk will have what subnet? It will be the only active interface on that subnet right ex on x.x.3.0 /24 network?
    Reply With Quote Quote  

  2. SS -->
  3. Junior Member Registered Member
    Join Date
    Aug 2017
    Posts
    1
    #2
    There isn't an IP number/subnet assigned to the router's physical interface which is used as the trunk. That's the whole point of configuring the subinterfaces! So, for example, assuming we're using subnetting the private Class C network 192.168.0.0/24, with VLAN 2 using the subnet 192.168.1.0/24 and VLAN3 using the subnet 192.168.3.0/24, you just need to enable (no shut) the physical port that is being used as the trunk to your switch, then go in and configure the subinterfaces.


    Router(config)#interface f0/1 (This is your physical interface/trunk leading to the switch)

    Router(config-if)#no shutdown
    Router(config)#interface f0/1.1 (This is your subinterface for VLAN 2)

    Router(config-subif)#encapsulation dot1q 2 (the number after dot1q is the VLAN number)

    Router(config-subif)#ip address 192.168.0.1 255.255.255.0 (this is the "default gateway" for the 192.168.0.0/24 subnet)

    Router(config)#interface f0/1.2 (This is your subinterface for VLAN 3)

    Router(config-subif)#encapsulation dot1q 3

    Router(config-subif)#ip address 192.168.1.1 255.255.255.0 (this is the "default gateway" for the 192.168.1.0/24 subnet)
    You don't need to assign any addresses in the 192.168.3.0/24 subnet. If you decide to do so, you should add another VLAN, for example VLAN 30, to associate it with:

    Router(config)#interface f0/1.3

    Router(config-subif)#encapsulation dot1q 30

    Router(config-subif)#ip address 192.168.3.1 255.255.255.0
    Reply With Quote Quote  

  4. Senior Member lantech's Avatar
    Join Date
    Mar 2012
    Location
    Mesa, Az
    Posts
    320

    Certifications
    MCSE, A+
    #3
    The physical interface on the router won't have an IP address. Only the sub interfaces do.
    Reply With Quote Quote  

  5. Junior Member nole07's Avatar
    Join Date
    Jun 2017
    Posts
    14

    Certifications
    CCENT, Comptia A+, Comptia Network+
    #4
    The physical interface can have an ip address though. you can have an ip address for fa0/0, etc... and then the subinterfaces can all have ip addresses for their respective vlans.
    Reply With Quote Quote  

  6. RS6
    RS6 is offline
    Junior Member Registered Member
    Join Date
    Dec 2015
    Posts
    4
    #5
    THanks!!!!
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks